Back to overview
Downtime

InfiniCount | Downtime

Jun 12, 2026 at 9:08pm UTC
Affected services
infinicount.foxstudiosscratch.cc

Resolved
Jun 13, 2026 at 4:01pm UTC

We have found the cause and pushed a fix

Created
Jun 12, 2026 at 9:08pm UTC

We are aware of both downtime and are actively investigating.