Global Outage | AWS Outage
Resolved
Oct 20 at 10:22am ADT
AWS is back up, leading to the successful restoration of all of our services. We thank you for your patience during this downtime.
Affected services
Created
Oct 20 at 08:59am ADT
We are currently experiencing a major service disruption due to a widespread Amazon Web Services (AWS) outage impacting multiple regions globally. This incident is affecting thousands of companies and platforms worldwide, not just Fox Studios - Scratch™. Our team is actively monitoring AWS’s recovery efforts and will restore all services as soon as their systems stabilize. Updates will be posted here as soon as more information becomes available.
Affected services